菜单 学习猿地 - LMONKEY

 jquery不兼容低版本ie浏览器怎么办?

jquery不兼容低版本ie浏览器怎么办?

Charles2018 profile image Charles2018 ・1 min read

jquery不兼容低版本ie浏览器怎么办?

1、可以使用原生JS或者低版本的Jquery1.x版本。因为Jquery从2.x版本开始已经不再进行IE低版本(IE6、IE7、IE8)的兼容性处理。如果需要兼容低版本的IE版本,建议使用原生JS或者低版本的Jquery1.x版本。

2、可以给网页写两套或者多套JS代码以适应不同版本、不同类型的浏览器,然后使用原生JS判断浏览器的型号和版本来加载不同的JS文件。

jquery简介:

jquery是一套跨浏览器的JavaScript库,简化HTML与JavaScript之间的操作。由John Resig在2006年1月的BarCamp NYC上发布第一个版本。目前是由 Dave Methvin 领导的开发团队进行开发。全球前10000个访问最高的网站中,有59%使用了jquery,是目前最受欢迎的JavaScript库。

评论 (0)