菜单 学习猿地 - LMONKEY

升级sharepoint2013遇到的坑

dq-optional profile image dq-optional ・1 min read

现在要将sharepoint2010,ProjectServer2010升级到2016的版本,需要先升级到2013的版本。

按照官方文档,瞎搞将sharepoint2010升级到2013的版本,中间出现很多警告,没当回事,继续把2013的wsscontent数据库还原到2016的服务器上升级。

因为在升级2013的过程中,很多警告未处理,直接导致了升级2016的失败,截图如下:

升级不下去了,查看日志才发现是之前升级2013的警告未处理掉导致的。

根据日志提示:

[SharePoint - 80] 应用程序配置了 claims 身份验证模式,但是您尝试连接的内容数据库应在 windows classic 身份验证模式下使用。

搜了下才知道,从2010升级到2013身份认证模式变了。

找了很多资料,需要将认证模式从windows classic转换到claims 身份验证模式

但官方文档一直给出的命令是

Convert-SPWebApplication -Identity http://sp2013-app2:81 -From Legacy -To Claims -RetainPermissions

但无论怎么敲命令,提示报错没有-From这个参数,搜了很多资料,告知是没有打补丁导致的,于是去下载官方的补丁,下载了很多,除了SP1的补丁安装成功,其他补丁都没成功,不知道为什么。网上资料说要2014年6月的补丁,但官网也没这个补丁,往2014年以后的补丁去打,没有一个成功的。

绝望了。。。

但我想想好像不一样是补丁的问题,可能是我的命令问题。

于是继续找资料

终于搜到一遍资料,使用如下名下转换:

Convert-SPWebApplication -Identity "http://sp2013-app2:81" -To Claims –RetainPermissions -Force

直接去掉From参数,这不是坑我吗???

就这样,没有打补丁,身份认证模式转换成功。

这里面在下载各个补丁等待了太久时间,一个补丁1.4G,下载了7-8个,痛苦的经历。

希望后来人能避开这个坑。

于是重新将WSS_content备份到2016数据库服务器上去升级,还是报错,只是没了身份认证的错误,其他错误又来了,头大了。

继续研究吧,我还能说什么。。。

 

评论 (0)