菜单 学习猿地 - LMONKEY

VIP

开通学习猿地VIP

尊享10项VIP特权 持续新增

知识通关挑战

打卡带练!告别无效练习

接私单赚外块

VIP优先接,累计金额超百万

学习猿地私房课免费学

大厂实战课仅对VIP开放

你的一对一导师

每月可免费咨询大牛30次

领取更多软件工程师实用特权

入驻
316
0

HDU1027

原创
05/13 14:22
阅读数 34815

Ignatius and the Princess II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9858    Accepted Submission(s): 5760


Problem Description
Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"
Can you help Ignatius to solve this problem?
 

 

Input
The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.
 

 

Output
For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.
 

 

Sample Input
6 4
11 8
 

 

Sample Output
 
1 2 3 5 6 4
1 2 3 4 5 6 7 9 8 11 10
 
分析:我题目都看了好久。。。。。。。
题目是求1,2,3......n这个序列按照1,2,3...这个字典的排序
比如:
3 1
1 2 3

3 2
1 3 2

3 3
2 1 3

3 4
2 3 1

3 5
3 1 2

3 6
3 2 1
用到了一个函数next_permutation,第一次用。。。。。。,好好用啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊啊
代码如下:
#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n,m;
    while(~scanf("%d %d",&n,&m))
    {
        int a[n];
        int k=1;
        for(int i=0;i<n;i++)
        {
            a[i]=i+1;
        }
        while(next_permutation(a,a+n))
        {
            k++;
            if(k==m)
                break;
        }
        printf("%d",a[0]);
        for(int i=1;i<n;i++)
        {
            printf(" %d",a[i]);
        }
        printf("\n");
    }
    return 0;
}

 

发表评论

0/200
316 点赞
0 评论
收藏