菜单 学习猿地 - LMONKEY

VIP

开通学习猿地VIP

尊享10项VIP特权 持续新增

知识通关挑战

打卡带练!告别无效练习

接私单赚外块

VIP优先接,累计金额超百万

学习猿地私房课免费学

大厂实战课仅对VIP开放

你的一对一导师

每月可免费咨询大牛30次

领取更多软件工程师实用特权

入驻
176
0

Talent Show

原创
05/13 14:22
阅读数 96408

6349: Talent Show

时间限制: 1 Sec  内存限制: 128 MB
提交: 106  解决: 40
[提交] [状态] [讨论版] [命题人:admin]

题目描述

Farmer John is bringing his N cows, conveniently numbered 1…N, to the county fair, to compete in the annual bovine talent show! His ith cow has a weight wiwi and talent level ti, both integers.
Upon arrival, Farmer John is quite surprised by the new rules for this year's talent show:

(i) A group of cows of total weight at least W must be entered into the show (in order to ensure strong teams of cows are competing, not just strong individuals), and

(ii) The group with the largest ratio of total talent to total weight shall win.

FJ observes that all of his cows together have weight at least W, so he should be able to enter a team satisfying (i). Help him determine the optimal ratio of talent to weight he can achieve for any such team.

 

输入

The first line of input contains N (1≤N≤250) and W (1≤W≤1000). The next N lines each describe a cow using two integers wi (1≤wi≤106) and ti (1≤ti≤103).

 

输出

Please determine the largest possible ratio of total talent over total weight Farmer John can achieve using a group of cows of total weight at least W. If your answer is A, please print out the floor of 1000A in order to keep the output integer-valued (the floor operation discards any fractional part by rounding down to an integer, if the number in question is not already an integer).

 

样例输入

3 15
20 21
10 11
30 31

 

样例输出

1066

 

提示

In this example, the best talent-to-weight ratio overall would be to use just the single cow with talent 11 and weight 10, but since we need at least 15 units of weight, the optimal solution ends up being to use this cow plus the cow with talent 21 and weight 20. This gives a talent-to-weight ratio of (11+21)/(10+20) = 32/30 = 1.0666666..., which when multiplied by 1000 and floored gives 1066.

观察ti和wi和.设sum(ti)/sum(wi) = x.则有sum(ti) = sum(wi)*x. 进一步得出sum(ti)-sum(wi)*x = 0.展开后利用加法交换律得到sum(ti-wi*x) = 0. 此时发现ti,wi可以枚举,只留下x不确定,然后结果要求是0。考虑二分x,若加起来的和>0,说明x的值小了,若加起来的和<0,说明x大了,然后考虑到和的问题。

求和的问题明显可以看作是0-1背包问题,即dp[i]表示重量为i的情况下,可获得的最大值。然后发现此时的背包容量可以是特别大,而没有具体值,将重量大于W之后的值都当作W看待。对于dp[W],若他大于等于0,说明mid小了,否则说明mid大了。

再者0-1背包的过程中,由于背包的容量没有上限,所以背包的权值可以是在0到W+wi,所以二维dp维护的过程中可以将j-wi变成j+wi。,然后再进行背包。

最后得到结果,为了方便计算,可以在开始的时候就将ti*1000,即被除数扩大1000倍,这样结果自然扩大了1000倍,用long long计算,解决了向下取整的问题。

 注:二分时,if成立,则需要向下取整,即ans=mid;否则,ans=mid-1.

AC代码:

#include <bits/stdc++.h>
using namespace std;
#define N 300
#define ll long long
#define inf 1LL<<60
int n,m,t[N],w[N];
ll dp[1200];
bool jud(int mid)
{
for(int i=1; i<=m; ++i)
{
dp[i]=-inf;
}
for(int i=1; i<=n; ++i)
{
ll v=t[i]-(ll)w[i]*mid;
for(int j=m; j>=0; --j)
{
if(dp[j]==-inf)
{
continue;
}
int jj=j+w[i];
if(jj>m)
{
jj=m;
}
dp[jj]=max(dp[jj],dp[j]+v);
}
}
return dp[m]>=0;
}
int main()
{
scanf("%d %d",&n,&m);
for(int i=1; i<=n; ++i)
{
scanf("%d %d",&w[i],&t[i]);
t[i]*=1000;
}
int l=0,r=1000000;
while(l<=r)
{
int mid=(l+r)/2;
if(jud(mid))
{
l=mid+1;
}
else
{
r=mid-1;
}
}
printf("%d\n",r);
return 0;
}

发表评论

0/200
176 点赞
0 评论
收藏
为你推荐 换一批