菜单 学习猿地 - LMONKEY

VIP

开通学习猿地VIP

尊享10项VIP特权 持续新增

知识通关挑战

打卡带练!告别无效练习

接私单赚外块

VIP优先接,累计金额超百万

学习猿地私房课免费学

大厂实战课仅对VIP开放

你的一对一导师

每月可免费咨询大牛30次

领取更多软件工程师实用特权

入驻
227
0

PAT 甲级 1024 Palindromic Number (25 分)(大数加法,考虑这个数一开始是不是回文串)

原创
05/13 14:22
阅读数 93950
1024 Palindromic Number (25 分)
 

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤) is the initial numer and K (≤) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and Kinstead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3

题解:

  一开始便直接考虑用大数加法以防万一。第一次提交发现测试点2和测试点3没过,自己分析出了原因,可能在不加之前就已经是回文串,即k=0,还有单个数字也是回文串。

5 100
5
0
131 500
131

  本题考查的是数的相加和逆序,本属于简单题,但是本质考查了大数相加的知识。未注意到大数相加会导致测试点6和测试点8(从0开始)未通过。理由是本题的N的范围是(0,1010],k的范围是(0,100],我们考虑最坏的情况,假设N是一个非常逼近1010的值并且进行了100步操作依然未得到回文值,则简单推测可知计算过程中遇到的最大值是2100*1010,这个值超出了long long int(263-1,约9.2*1018)表示范围,因此需要用char存储数的值。

AC代码:

#include<bits/stdc++.h>
using namespace std;
char a[101];
char b[101];
char c[101];
int n;
int main(){
    cin>>a;
    cin>>n;
    int l=strlen(a);
    for(int i=0;i<l;i++){
        b[i]=a[l-i-1];
    }
    //先检查第0代它本身是不是回文
    int f=1; 
    int mid=(l-1)/2;
    for(int j=0;j<=mid;j++){
        if(a[j]!=a[l-j-1]){
            f=0;
            break;
        }
    }
    if(f){
        cout<<a<<endl;
        cout<<0;
    }
    else{//再考虑第1代及以后 
        int k=-1;
        for(int i=1;i<=n;i++){
            //加起来得到一个新的值
            int x=0;
            for(int j=0;j<l;j++){
                x=a[j]-'0'+b[j]-'0'+x;
                c[j]=x%10+'0';
                x=x/10;
            }
            if(x>0){
                c[l++]=x+'0';
            } 
            //检查符不符合要求
            mid=(l-1)/2;
            f=1;
            for(int j=0;j<=mid;j++){
                if(c[j]!=c[l-j-1]){
                    f=0;
                    break;
                }
            }
            if(f){//是回文 
                k=i;
                break;
            }
            for(int j=0;j<l;j++){//更新 
                a[j]=c[j];
                b[j]=c[l-j-1];
            }         
        }
        for(int i=l-1;i>=0;i--){//输出结果 
            cout<<c[i];
        }
        cout<<endl;
        if(k!=-1){//还没到n代 
            cout<<k<<endl;
        }else{     
            cout<<n<<endl;
        }    
    }
    return 0;
} 

 

 

学一下别人简洁得代码:

#include <iostream>
#include <algorithm>
using namespace std;
string add(string a){
    string ans=a;
    reverse(a.begin(),a.end());
    int i=a.length()-1,add=0;
    while(i>=0){
        int tmp=a[i]-'0'+ans[i]-'0';
        ans[i]=(add+tmp)%10+'0';
        add=(tmp+add)/10;
        i--;
    }
    if(add) ans.insert(0,"1");
    return ans;
}
int main(){
    string s;
    int k;
    cin>>s>>k;
    string tmp=s;
    reverse(tmp.begin(),tmp.end());
    if(tmp==s) cout<<tmp<<endl<<0;
    else{
        int i=0;
        while(i<k){
            s=add(tmp);
            i++;
            tmp=s;
            reverse(tmp.begin(),tmp.end());
            if(tmp==s) break;
        }
        cout<<s<<endl<<i;
    } 
    return 0;
}

 

发表评论

0/200
227 点赞
0 评论
收藏
为你推荐 换一批